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Summary:  An Human Machine Interface (HMI) can be set up to command up to 16 
JUSP-NS600 Sigma II Indexers over a dedicated serial network*.  Using an HMI for 
command provides an easy to use interface for the user and allows for quick 
reconfiguration of the Sigma II Indexers.  Over 100 commands for initialization, control, 
monitoring, and diagnosis are available to the HMI. 
 

 
Figure 1. – Typical Control Architecture* 

 
Purpose:  The purpose of this document is to explain the functionality of using an HMI to command the 
Sigma II Indexer (or a network of Indexers) and to provide helpful tips when doing so.  This document 
specifically deals with the Yaskawa Commander (EXOR) series of HMIs, but much of the information is 
relevant to the use of any HMI.  Set up and programming tips for the Sigma II Indexer will not be covered 
in this document.  For a list of supplemental documents, refer to appendix A.  A typical bill of materials for 
using a Yaskawa Commander (EXOR) is available in engineering document “Summary of HMI and Sigma 
II Indexer Control Systems“ (pub. # eng/01.050/MCD). 
 
 
Functional Description 
 
An HMI allows the user to start execution of any of the 128 index table commands.  By linking the 
commands in the index table, preset programs can be set up.  A menu can be set up allowing the user to 
select one of these programs from a descriptive job list.  In addition, an HMI has the capability to set up 
recipes of index table commands and parameters allowing the user to quickly rewrite the index table or 
change the servomotor’s characteristics with the push of a single button.  Monitoring capabilities are also 
included allowing the user to monitor program, motion, alarm status, and more.  
 
                                                           
* This is NOT a network for real-time control, but works well for limited control, set-up and 
monitoring.   
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The Yaskawa Commander (EXOR) series offers an optional HMI-OPLC-30 internal PLC module, which 
provides internal HMI logic.   This internal logic allows for more elaborate command than an HMI alone 
typically provides.  The PLC can have commands sent to the Indexer by requesting them through the HMI.  
Therefore the PLC can set up a batch routine by starting an index program, polling for completion of the 
task, and then repeating.  The PLC is a completely separate entity from the HMI, but is closely tied to the 
HMI.  The HMI can read/write directly to variables in the PLC letting the user monitor and/or edit them 
through the panel.  The PLC can monitor and have limited control over the HMI through the Reserved 
Data Area (RDA) and through the Interlock Mailbox.  The PLC can monitor the HMI’s buttons, request 
recipe downloads, change the page that is displayed, turn on/off panel LEDs and more. 
 
 
Hardware Considerations 
 
 General considerations for any HMI 

• The Indexer will only repeat a single step, not a group of steps.  To repeat a group of steps, a 
batch program must be set up in the PLC. 

• This is NOT a control network.  The HMI cannot respond in real-time.  Because of this reason, 
emergency stop circuits should be hardwired. 

• Limited to 50m serial communication cable for RS422 (and RS485) communication. 
 
 Considerations specific to the Yaskawa Commander (EXOR) HMI series 

• Serial commands to the Indexer that are requested by the PLC can be made at a maximum 
frequency of 2/second based on the HMI’s read cycle time of the interlock mailbox. 

• In general, the HMI will only respond to button presses.  Therefore, the HMI will only send a 
serial command, change the page, etc. when a button is pressed.  For example, the HMI can 
download settings to the Indexer and start an index program, but it CANNOT poll the Indexer for 
completion and then start a new program.  The HMI-OPLC-30 internal PLC will be required for 
situations such as this. 

• The HMI-OPLC-30 has a scan rate of ~3ms per K. 
• An optional I/O module for the internal PLC is available on some Commander (EXOR) HMIs, 

which can be wired to the Indexer’s I/O port for quicker control and monitoring.  Check with a 
Yaskawa representative for a complete listing of HMIs that support the I/O modules. 
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TIPS/TRICKS FOR USING THE YASKAWA COMMANDER HMI WITH THE JUSP-NS600 INDEXER 
 

Setting Up 
• To download a Designer program, connect a serial cable to the COM port of your PC and to the 

PC/Printer port of the HMI.  The HMI must be in Configuration mode to download a program.  
Under normal conditions when a valid program is installed, the HMI will boot up in Operation 
mode.  To change to Configuration mode, hold down on the enter key for 3 seconds and select 
“CFG” from the menu that appears. 

• IndexWorks (used for initial setup of the Indexer’s parameters, program table, etc.) and the HMI 
require different communications settings on the Indexer.  IndexWorks requires that the Indexer 
be set up for RS422 w/echo back communication (Pn800=1) and the HMI requires that the 
Indexer be set up for RS422 w/o echo back communication (Pn800=0).  To change this parameter, 
open Terminal in IndexWorks and issue the command <Axis>Prm800=<com> where <Axis> is 
the axis setting set by the rotary switch on the Indexer and <com> is the desired communications 
setting – 0,1.  Cycle power on the Indexer for this setting to take effect. 

 
Programming Tips 

• To set up a new Designer project select Project->Change Controller Driver and then select 
Yaskawa Indexer from the dialog.  If more than one axis is being used, select Project->Controller 
Setup and set up the axes.  Select Project->Panel Setup and set the panel to be used in the project. 

• Recipe downloads MUST be allowed to fully complete before new serial commands to the 
indexer are issued.  To prevent users from issuing a command through the HMI before a recipe 
has completed, a wait timer can be set up when the recipe is downloaded.  NOTE:  The amount of 
time required to download a recipe is largely dependant on recipe size, but can also be affected by 
the load on the HMI (checking the interlock mailbox, refreshing variables on the screen, changing 
pages, etc.). 

• Be careful when programming the enter key on the HMI.  Setting up commands on the enter key 
will prevent the enter key from being used to access the configuration mode.  If the enter key has 
been programmed, hold down on any 3 keys when turning on power to boot the HMI into 
configuration mode. 

• When testing a program, watch for serial command errors.  They will not trip the alarm and will 
only flash the Indexer’s red status LED (STS) for two seconds.  Communication errors can 
sometimes also be spotted on the HMI as a blinking communication light.  These errors often 
result in serial commands being ignored.  Because all errors will appear as A.9F on the amplifier 
display, the easiest way to determine what error has occurred is with a digital operator (JUSP-
OP02A).  If one is unavailable, the serial command <Axis>ERR can be used to read the last error. 
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TIPS/TRICKS WHEN USING THE COMMANDER WITH THE INTERNAL SCM03 PLC 
 
Setting up 

• The document MMI-PLC operations.doc located on the Designer installation CD explains the 
hardware and software installation.  Designer is used for programming the HMI and ISaGRAF 
Workbench is used for programming the internal PLC. 

• EXOR tech note #tn137-0 “Control With UniOP” provides installation and programming 
information on using the HMI with the internal PLC.  The Sigma II Indexer will be set up as the 
external PLC. 

• To compile a Workbench program, the special protection key that comes with the software must 
be installed on the parallel port.  Windows NT users must install an additional program called 
Sentinel located on the installation CD. 

• A Workbench program can be downloaded on either the PC/Printer port or the PLC port.  When 
downloading to the PC/Printer port the HMI must be in Operation mode.  When downloading to 
the PLC port the HMI must be in Configuration mode.  To select the desired port go to System 
mode (hold enter for 3 seconds and select “SYS” from the menu).  Scroll down and select 
“SCM#0 A” on either the PLC or PRINTER selection. 

 
Programming Tips 

• To compile a Workbench program for downloading to the PLC, open the project and from the 
programs window select Make->Compiler Options and select “EXOR: TIC code for EXOR 
(Intel)” in the dialog box.  Then select Make->Make Application.  To download it, select 
Debug->Debug.  From the debug window select File->Stop Application to stop any 
application that might be running.  Then select File->Download. 

• The PLC CANNOT directly send and receive data through the serial PLC port.  The PLC 
must request that the HMI do that on its behalf. 

• There are several ways for the HMI and PLC to communicate with one another. 
o Any variable in the PLC program may be given a network address and referenced in 

Designer using the Tag Editor. 
o The Reserved Data Area (RDA) sets up a data area on the internal PLC that the HMI 

reads and writes in.  This gives the PLC limited ability to monitor and command the 
HMI.  See Fig 7-2 in the Designer Manual for more information. 

o The Interlock Mailbox also sets up a data area on the internal PLC.  The PLC can 
write commands to the HMI here.  The HMI then periodically checks the mailbox 
receiving the commands.  One of the commands that the mailbox allows the PLC to 
command the HMI to begin is a Data Transfer job.  The Data Transfer jobs can then 
be set up to send various commands/inquiries to the Indexer.  This provides an 
indirect way for the PLC to command the Indexer. 

• Just as it is important that users be prevented from issuing serial commands before recipe 
downloads are complete, it is important that the PLC does not request a serial command 
through the interlock mailbox before recipe completion.  By setting up the Reserved Data 
Area in the HMI, the PLC can directly monitor whether or not a recipe is being downloaded 
using S14 of the Panel Status Word and hold its commands until completion. 

• A sample application using the Yaskawa Commander (EXOR) HMI-G4X20M-31 with the 
internal PLC was created.  The files can be found at Yaskawa’s ftp site 
ftp://ftp.yaskawa.com/public/development/servo/indexer/hmi.  The Designer file, 
NS600HMI.prj, was used for programming the HMI.  The ISaGRAF Workbench folder, 
NS600HMI, contains the project used for programming the internal PLC.  A printout of the 
PLC code used is provided in figure 2 as an example. 
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(* If the HMI is on page 1 - the splash screen (RDA0=1), then wait 3 seconds and request that the page be changed to page 10 - servo on screen (RDA3=10) *)

(* If page 10 is requested (RDA3=10) and page 10 is displayed (RDA0=10) then return page control to the HMI (RDA3=0).  The timer is inserted to prevent lock-ups. *)

(* When run is activated, reset for new run *) 

(* Check to see if mailbox is busy *) 

(* If the servos have been started, but the run has not been completed, initiate command to check whether Axis 0 has 
fi i h d   Include timer to allow time for each serial command to complete.  (StatusWord=1, CommandWord=49, Parameter0=2) *)

(* When a batch is being run and the servos are not yet started, initiate command to start as soon as mailbox is free.
   (StatusWord=1, CommandWord=49 => Mailbox0=1+49*65536=3211265   |   Parameter0=1, Parameter1=0 => Mailbox1=1+0*65536=1) *)

(* When run is completed, increment counter. *) 

(* After run is completed, wait 1 second for any additional mailbox requests to complete and then reset variables for another
    run *) 
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Figure 2. – PLC Ladder Code for HMI for Sigma II Indexer Command Demo 
 

NOTE:  Reference Workbench manual for more information on programming the HMI-OPLC-30. 
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Appendix A – Supplemental Documents 
 
1. Yaskawa Sigma II Indexer User’s Manual. YEA-SIA-S800-32.11 
2. EXOR Designer for Window’s User’s Manual  
  http://www.exor-rd.com/Support/SoftwareManual/ 
3. ISaGRAF Workbench User’s Guide.  Located on UniWin-CD. 
4. MMI+PLC – Operating Instructions.  Located on UniWin-CD. 
5. EXOR tn137-0, Control with UniOP. 
  http://www.exor-rd.com/Support/TechNotes/ 
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